Crunchez vos adresses URL
|
Rejoignez notre discord
|
Hébergez vos photos
Page 19 sur 22 PremièrePremière ... 9111213141516171819202122 DernièreDernière
Affichage des résultats 541 à 570 sur 655
  1. #541
    Merci.
    Pour l'instant je galère avec Node Red alors on va attendre un peu pour aller sur plus compliqué . Je suppose que les hubs font chier par défaut et que je dois désactiver les automatismes genre l'allumage des ampoules tradfri par le détecteur de mouvement tradfri ?
    Y a un site qui référence les senseurs (mouvement, luminosité, température, humidité, occupation, ...) ?

  2. #542
    Tu supposes parfaitement bien.
    Les ponts propriétaires ont des fonctions de serveur domotique. Le plus simple c'est de ne pas utiliser ces dernières. Ton pont ne sert que de modem pour le réseau zigbee (normalement tous les ponts bouffent toutes les entités zigbee. Normalement...) et pour mettre à jour le firmware de tes entités de la marque sans te faire chier.

    Je ne gère aucune automatisation via le pont Hue par exemple (même entre un switch et une ampoule hue), tout passe par Hass.io. Au moins quand tu as une merdre, tu ne regarde qu'à un endroit.

    Pour ta liste de senseurs... c'est compliqué et très simple. Dis ce que tu souhaites mesurer et il y aura une solution. La domotique actuelle version DIY est très proche de la communauté Pi et Arduino (c'est même de là que ça vient) et question interaction HW on est dans cet écosystème bien documenté.

    En produits commerciaux, tu as des capteurs IR (présence), de luminosité, de vibration / choc, de contact, d'humidité, de température, de vitesse du vent, de précipitations, des capteurs RFID oupas, des gyroscopes/accéléromètre (comme le Xiaomi Cube).... Sans compter des trucs bien documentés dans les applis robotiques sous forme de kits....

    Tu vas me dire que je fais une fixette, mais je pense qu'il faut d'abord te demander ce que tu cherches à mesurer et ensuite seulement les modalités techniques pour le faire.
    Tu peux par exemple évaluer la présence de plein de manières différentes : Le passage (IR), le fait qu'un téléphone soit connecté à ton wifi/BT, le fait qu'il y ait une conso électrique supérieure dans l'appart, la luminosité, l'appui sur un bouton... L'avantage de la domotique c'est que tu peux combiner ces senseurs pour en faire un plus complexe. Tu vas définir -pour rester dans l'exemple- que si ton tel est connecté sur le WiFi et que ton ordi est allumé ou que la lumière des chiottes s'est déclenchée 2 fois depuis que la porte d'entrée a été ouverte, et bien l'appartement est occupé, par toi.

    Chuis encore clair ?

    Si c'est le cas je vais quand même préciser UNE exception.
    Dans l'écosystème Hue "Rich Color" (donc uniquement les luminaires RGBW de la marque) il y a une fonction très sympa, Hue Sync qui synchronise ton éclairage avec ton écran (ou l'écran de ton voisin, mais c'est con). Elle n'est gérée que par le pont Hue via le soft HueSync.
    A ce jour, je ne suis encore tombé sur aucune solution qui permettrait de répliquer cette fonction (enfin si... y'a des trucs mais qui impliqueraient des luminaires spécifiques aussi et commandés avec du Pi, donc au final aussi cher qu'une ampoule Hue en promo...)

    Donc si tu veux HueSync, pas le choix => Pont Hue et les ampoules dessus.
    Dernière modification par Daedaal ; 20/12/2019 à 12h35.
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  3. #543
    C'est clair.
    Je répondrai plus en détail ce soir.

    Donc je désappaire tout et j'utilise hass.io pour tout appairer ? Faur pas approcher les ampoules tradfri super près du hub ?

  4. #544
    non non
    Tu laisse tes trucs appairés tels quels. Tu vires les automatismes du pont donc tout les autres que ceux de hassio et c'est bon.

    L'appairage c'est le rôle de modem. C'est comme faire un WPS sur ton réseau wifi. Une fois que tu as appairé, hassio va remonter les entités et c'est avec lui / NodeRed que tu bidouilles.

    Comme le consommateur lambda veut un machin out of the box ou presque, en plus du modem ton pont inclut un serveur domotique qui permet de faire un certain nombre de choses. L'idée c'est de faire le minimum (enfin rien) au niveau du serveur domotique du pont, mais tout au niveau d'hassio (ou équivalent). Beaucoup plus de flexibilité et de possibilités que le pont constructeur seul.


    Vraiment, penses chacune des entités domotiques comme des tout pitipiti ordinateurs tout simples. L'appairage, c'est les mettre en réseau. Les remonter sur le pont ou dans hassio c'est les identifier avec un serveur central pour ensuite les faire interagir (c'est les automatismes, NodeRed, etc...).
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  5. #545
    Hmmm j'ai aucune automation sur l'application tradfri. Après j'ai appairé les lumières par le biais des détecteurs de mouvement.

  6. #546
    Citation Envoyé par Snakeshit Voir le message
    Hmmm j'ai aucune automation sur l'application tradfri. Après j'ai appairé les lumières par le biais des détecteurs de mouvement.
    Possible que le problème vienne de là. Si j'ai bien compris, le souci c'est que tu as des ampoules qui répondent aux détecteurs alors que tu ne leur a rien demandé ?

    Dans ce cas, c'est sans doute une routine destinée à faciliter l'usage des gens qui achètent ça comme une télécommande (en gros, le fabricant ajoute une sous-couche serveur dans certaines entités. Une sorte de sous-pont zigbee avec un micro serveur de chie. On détaille pas, c'est horrible).

    Premier essai, je virerais les ampoules du pont puis je les ajouterais à nouveau direct sur le pont via l'appli comme si tu venais de les acheter. Donc tu fais un reset de chaque ampoule (clic-clic-clic-clic....à et tu les rentres à nouveau mais via l'appli.
    'faudra peut-être un reboot à hassio pour les remonter. Toute façon, c'est jamais mauvais de le redémarrer.

    Au pire 'faudra faire la même avec les détecteurs aussi (bouton derrière).

    Si ça peut te rassurer, tous mes kits détecteur/télécommande/ampoule tradfri marchent en tant qu'entités indépendantes. Mais je les appairées une à une direct sur mon pont. Donc...
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  7. #547


    L'appairage, c'est ce qui permet la communication entre pont et entités dans le protocole kivabien (zigbee pour tradfri et en général). Rien de plus.

    Le serveur domotique ne gère pas (physiquement) l'appairage, il se "contente" de donner des instructions logiques aux entités que lui remontent le/les ponts (et le réseau wifi, le BT... tout).
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  8. #548
    Disons que les ampoules agissemt comme d'habitude au lieu de répondre à hass.io. mais tradfri c'est une purge à appairer comparé à hue .
    Le coup des 2 cm du routeur .... à la limite je les appaire au hue pour réduire le nombre de hub.

  9. #549
    Pour hassio, qu'ils soient appairés au pont hue ou à un autre c'est la même chose. Donc go le plus commode.
    Si le pont Hue les bouffe (je ne vois pas de raison que ça ne fonctionne pas), pas de raison de garder un autre pont.


    (et le coup des 2cm du pont... c'est généralement du pipo pour se couvrir)
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  10. #550
    Citation Envoyé par Daedaal Voir le message
    Pour hassio, qu'ils soient appairés au pont hue ou à un autre c'est la même chose. Donc go le plus commode.
    Si le pont Hue les bouffe (je ne vois pas de raison que ça ne fonctionne pas), pas de raison de garder un autre pont.


    (et le coup des 2cm du pont... c'est généralement du pipo pour se couvrir)
    Je réessayerai mais peut-être après les vacances. Merci !
    Citation Envoyé par Lt Anderson Voir le message
    Et viens pas me faire la leçon, tenshu, [...], j'ai le recul que tu n'as pas, alors que tu restes avec ton nez collé sur le mur de tes fantasmes politiques (de tes haines?).

  11. #551
    Citation Envoyé par Daedaal Voir le message
    Premier essai, je virerais les ampoules du pont puis je les ajouterais à nouveau direct sur le pont via l'appli comme si tu venais de les acheter. Donc tu fais un reset de chaque ampoule (clic-clic-clic-clic....à et tu les rentres à nouveau mais via l'appli.
    Je crois que c'est là la blagounette Ikea : tu ne peux pas ajouter d'équipement directement sur le pont. Leur procédure d'appairage c'est qu'il faut que tu appaires une commande (détecteur, variateur ou interrupteur) au pont puis que tu te serves de ta commande appairée pour aller appairer ton ampoule/prise. Ton ampoule/prise apparaitra ensuite sur le pont dans la même "pièce" que ta commande et tous les équipements appairés à l'aide de ta commande réagiront à cette commande. Après tu peux toujours reset la commande pour rendre tes ampoules/prises "indépendantes"

  12. #552


    Même chez Hue ils ne sont pas aussi cons que ça. En plus ça me paraît assez contraire à la norme Zigbee qu'Ikea est fier de poser sur les emballages de ses produits Tradfri.

    Une entité zigbee, c'est une entité zigbee. En mode d'appairage, elle va tenter de se connecter au pont avec le plus gros signal qui est en mode "ouvert". Et ensuite au mesh se lier.
    En toute franchise j'ignore si tu peux connecter une entité zigbee sans qu'elle ne soit directement à portée d'un pont (donc à travers le mesh). Dans l'absolu, je dirais non, et on va conserver ça comme bonne pratique. Par contre, une fois appairée une entité n'a plus besoin que d'un point d'entrée sur le mesh (AKA n'importe quelle autre entité).
    Parfois le pont, c'est une télécommande ou un sensor (voir plus haut dans mes posts). Parfois, c'est appairé d'usine (souvent avec les kits) avec un pont prédéfini (mais y'a qu'à relancer une procédure de connexion).

    Mais dans tous les cas, un pont en mode "j'accepte les nouveaux" (c'est la procédure d'appairage côté pont), ben c'est ce qu'il fait. Aucune raison qu'il refuse une entité, c'est un peu le principe.

    Le truc que tu décris c'est l'interface tradfri je suppose (ou une grosse confusion dans les notices et les infos sur le sujet qui sont souvent merdiques). Si tu attaques le pont avec hass.io ou un autre serveur domotique, tu devrais voir chaque entité différenciée dès l'appairage.
    Dernière modification par Daedaal ; 28/12/2019 à 20h43.
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  13. #553
    Citation Envoyé par Daedaal Voir le message


    Même chez Hue ils ne sont pas aussi cons que ça. En plus ça me paraît assez contraire à la norme Zigbee qu'Ikea est fier de poser sur les emballages de ses produits Tradfri.
    C'est pas moi qui ait fait la conception des produits hein, je me contente de raconter la procédure
    Une fois que c'est connecté c'est bon tout est indépendant, mais pour les connecter tu dois passer par un controlleur

    A partir de 1:55
    Dernière modification par DrGurdil ; 28/12/2019 à 23h23.

  14. #554
    Ouais, alors ouais mais non.

    Je vois le "truc".

    Tu as la même chez Hue.
    La télécommande se comporte comme un pont. Donc effectivement en relai du pont "principal" et ça t'évite de devoir déplacer les ampoules. Ou pas que, parce que tu peux également pairer avec le pont principal en parallèle. Et chez Hue, c'est le bourdel pour remonter les infos du pont secondaire lui même (les boutons de la télécommande).
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  15. #555
    J'ai décollé 2 de mes 4 lightstrip +

    Le plastique s'est déchiré presque tout le long

    Ils doivent avoir 2 ou 3 ans max

    Bref c’est hyper fragile je pensais pas

  16. #556
    Hop, j'ai commencé la domotisation de mon chez-moi, et... c'est un de ces bordels

    J'ai 2 contraintes de base :
    1/ Hors de question que le net soit nécessaire pour allumer la lumière (par exemple, mais c'est valable pour tout), et si je peux éviter que mes datas se baladent dans la nature je préfère
    2/ Je veux conserver des boutons physiques pour la lumière histoire que des invités, ou moi en pleine nuit pas réveillée, soient capables d'allumer la lumière sans smartphone ou devoir gueuler sur google.

    En partant de là, j'ai pris un Raspberry Pi, installé Hass.io, et branché dessus un dongle Zigbee ZiGate.

    Jusque là, tout va bien, ça m'a pris 2h montage compris.

    J'ai acheté une prise connectée OSRAM Smart+, l'appairage et la commande m'ont pris 2 minutes ouverture du paquet inclus, ça marche impec.

    C'est après que ça merde.

    J'ai pris aussi, pour tester, un OSRAM Smart+ Mini Switch, et une ampoule OSRAM Smart+ E27 dimmable, censés être compatibles avec mon bazar.

    Et alors là... Au branchement, l'ampoule a trouvé le réseau Zigbee, je pouvais la commander depuis l'app. Ensuite j'ai voulu ajouter la télécommande, mais impossible de l'associer au réseau. J'ai pu appairer la commande directement à l'ampoule (c'est 2 combinaisons de touches différentes, pour l'appairage Zigbee et pour l'appairage direct à une ampoule). Et depuis ça, l'ampoule n'est plus reconnue par la passerelle... J'ai tenté de reset l'ampoule, la commande, les 2, j'ai testé 2 intégrations Hass.io (zigate et ZHA), mais ça a rien changé.

    Ensuite, je regarde pour connecter mes luminaires de salon. Je les aime bien, et y'a 8 ampoules dessus en tout, donc hors de question que je remplace chaque ampoule par du connecté. Ca va me coûter un bras et être une horreur à paramétrer.
    Je voulais un variateur connecté sans neutre à foutre à la place de mes inter actuels, j'en ai pas trouvé qui ai l'air compatible avec la ZiGate et Home Assistant. Du coup je pense partir sur un inter sur piles que je vais coller au mur, et un micro module flanqué dans la boite électrique de chaque luminaire...

    J'ai visé cet inter double et ce micromodule pour l'instant.

    Bref, c'est super rigolo, mais je pense que je me suis beaucoup compliqué la tâche en voulant partir sur un truc auto hébergé et multi-marques. A terme, j'aimerai bien connecter toutes mes lumières, les volets roulants, la commande de chauffage... et c'est tout ce à quoi j'ai pensé pour le moment. Mais rien que ça, je pense que ça va me prendre des mois vu comme je galère à trouver du matos compatible...
    Citation Envoyé par Arteis Voir le message
    scie pieds sous terre

  17. #557
    Mais nan c'est pas le bourdel.
    Bienvenue dans la famille des gens qui -au XXIème siècle- sont heureux de voir une ampoule s'allumer quand on appuie sur un bouton.

    On y vas pas à pas, et tu en as déjà fait un paquet : Ça fonctionne !

    Le seul problème que tu rencontres n'est pas de ton fait, c'est une feature de ton switch : En regardant vite fait sur google (je n'ai pas ce switch osram, j'ai failli mais je le trouvais trop cher) il semble qu'on arrive éventuellement à sniffer le trafic zigbee du switch, mais qu'on n'arrive pas à l'appairer parce qu'il est à la fois switch et pont autonome. J'ai le même problème avec une télécommande Hue true light (je crois, j'ai abandonné).

    Donc, tu fous ton switch dans un coin.
    Tu fais le cycle de reset de ton ampoule à proximité de ton dongle zigbee et tu la récupérera dans hassio.
    Un truc que je me suis bricolé rapidement et que j'utilise très souvent, c'est un bout de câble avec une prise, une douille et un inter. C'est vachement plus facile pour faire les reset.

    Mais pour le switch, je crains que ce soit à ranger dans pertes et profits en attendant qu'un éventuel plugin pour ton pont l'intègre. Je ne suis même pas certain que si tu avais une passerelle OSRAM il serait remonté correctement.
    En jouant un peu de subtilité et de chance, tu peux peut-être réussir à l'appairer avec une ampoule qui resterait dans hassio quand même. Ca implique notamment que les deux soient sur le même canal zigbee. Mais c'est vraiment du bancal pur jus.

    Pour tes luminaires (comme pour le reste d'ailleurs), tu es sur la bonne voie : Des inters physiques là où ils sont indispensables. Par contre, tu pourra en remplacer/compléter certains par des détecteurs de présence par exemple.
    Aucun problème à priori avec les références que tu as choisi : Xiaomi Aquara offre une belle gamme avec un RQP sympa. J'ai des inters et capteurs de chez eux, et aucun problème jusqu'ici.

    Ouais bon, en fait un seul. Avec des Mi cubes (un dé avec gyroscope/accéléromètre ) dont j'ai un peu de mal à accéder à la face et à la rotation en même temps. Mais c'est moi qui m'y prend comme un manche, rien à voir avec les périphs.


    Pour les périphs, tu cherches quoi d'autre ? Généralement le problème c'est plus de trouver un bon prix qu'un périph.
    Chez Xiaomi tu as les capteurs de température/humidité/pression qui sont sympas par exemple.
    Pour tes télécommandes/inters, j'ai du Hue, du xiaomi et du tradfri (ikéa) sans aucun souci.
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  18. #558
    Ouais, pour le switch c'est mort, tant pis c'est pas bien grave. Je l'ai renvoyé du coup.

    Depuis hier soir j'ai aussi un autre soucis, c'est que régulièrement ma prise connectée OSRAM disparaît et je dois l'appairer de nouveau au pont. J'ai l'impression que dès que je passe le pont en mode "Join", il oublie le plug.

    Sinon je pense que tu as de bonnes ondes pour la domotique, alors que toutes mes précédentes tentatives pour appairer cette §$*%£ de lampe avaient échoué, la dernier tentative a été la bonne ! L'ampoule est de retour sur le pont, et je peux la commander, tout va bien.

    Dernier en date, j'ai reçu le switch Aqara ce matin. Pas de soucis pour l'appairage au pont, par contre j'arrive pas à commander des trucs avec, parce que les boutons sont vus comme des sensors, quand on appuie dessus ça change leur état, mais pas de manière ponctuelle.
    Pour clarifier :

    - 10h15, je clic le bouton gauche -> le sensor correspondant passe à "left_single"
    - 10h20, je reclic -> il se passe rien, parce que le sensor était resté à "left_single" donc pas de changement d'état vu de hassio, donc pas possible d'automatiser des trucs dessus.

    Et là j'ai l'impression que le pont l'a oublié.
    Je commence à me demander si c'est pas juste mon pont (ziGate) qui fait des trucs bizarres. Tu as quoi comme pont zigbee toi ?
    Un pote a un pont Aqara dont il se sert pas, je pense que je vais lui emprunter pour tester.
    Dernière modification par scie_sauteuse ; 17/01/2020 à 13h24.
    Citation Envoyé par Arteis Voir le message
    scie pieds sous terre

  19. #559
    Citation Envoyé par scie_sauteuse Voir le message
    Ouais, pour le switch c'est mort, tant pis c'est pas bien grave. Au pire je le revends.

    Depuis hier soir j'ai aussi un autre soucis, c'est que régulièrement ma prise connectée OSRAM+ disparaît et je dois l'appairer de nouveau au pont. J'ai l'impression que dès que je passe le pont en mode "Join", il oublie le plug.

    Sinon je pense que tu as de bonnes ondes pour la domotique, alors que toutes mes précédentes tentatives pour appairer cette §$*%£ de lampe avaient échoué, la dernier tentative a été la bonne ! L'ampoule est de retour sur le pont, et je peux la commander, tout va bien.

    Dernier en date, j'ai reçu le switch Aqara ce matin. Pas de soucis pour l'appairage au pont, par contre j'arrive pas à commander des trucs avec, parce que les boutons sont vus comme des sensors, quand on appuie dessus ça change leur état, mais pas de manière ponctuelle.
    Pour clarifier :

    - 10h15, je clic le bouton gauche -> le sensor correspondant passe à "left_single"
    - 10h20, je reclic -> il se passe rien, parce que le sensor était resté à "left_single" donc pas de changement d'état vu de hassio, donc pas possible d'automatiser des trucs dessus.

    Et là j'ai l'impression que le pont l'a oublié.
    Je commence à me demander si c'est pas juste mon pont (ziGate) qui fait des trucs bizarres.
    Un pote a un pont Aqara dont il se sert pas, je pense que je vais lui emprunter pour tester.
    Les switchs sont des sensors d'un point de vue domotique. Ils n'ont pas d'état "neutre". Tu appuie => il envoie le code kivabien (+ timestamp complet). Si tu n'appuie pas ça reste son état (le dernier connu).
    Si tu appuies à nouveau, il va te renvoyer le même code kivabien et le timestamp. Normalement au niveau de hassio, ça déclenche aussi un "state changed" sur lequel tu peux réagir.

    Après, je passe tout dans NodeRed : Quand j'ai commencé avec hassio l'interface de dev pour les automatismes et le reste c'était de l'édition de fichiers YAML. Merci bien, NodeRed me donnait une interface graphique pour gérer mes flux et je suis très client de ce mode de représentation. En plus, il permet de déployer en quelques secondes tes changements, ce qui est infiniment plus rapide que les autres méthodes de l'époque.
    Je n'ai pas essayé Cloud9 (je crois) qui est aussi un IDE pour hassio.

    Tu passes par quelle interface pour gérer tes automatismes ?


    Sinon, j'ai justement un switch aqara tout frais sorti de son emballage.
    Selon ce que tu utilises pour gérer les automatismes, je peux faire un rapide tuto.
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  20. #560
    Ahhh j'avais pas compris le fonctionnement des switchs en fait. Merci pour les explications ! Vu que je ne voyais pas de changement d'état je ne voyais pas comment j'allais l'utiliser, mais avec tes infos je vais réessayer.
    Pour l'instant j'utilise l'interface d'hassio pour configurer les automatismes.
    J'ai vu les trucs super que tu as fait avec NodeRed dans l'historique du topic, ça envoi du paté ! Si je suis limitée par l'interface d'Hassio je pense passer là dessus aussi du coup.

    Par contre mon pont a bel et bien oublié le switch. J'ai l'impression que c'est ce bug : https://github.com/fairecasoimeme/ZiGate/issues/38
    Je verrai si ça fonctionne mieux avec le pont Xiaomi de mon pote.
    C'est vraiment super fun à faire en fait tout ça :D
    Citation Envoyé par Arteis Voir le message
    scie pieds sous terre

  21. #561
    Et la petite incise kivabien sur NodeRed. C'est le système de programmation IoT d'IBM, donc complet (très) et robuste. L'intégration avec hassio est suivie comme le lait sur le feu donc pas de problème de compatibilité.
    De ce que j'ai compris du bouzin, il compile à partir de tes flows et c'est ce fichier compilé qui est utilisé par hassio. Donc en termes de perfs, je pense (innocemment) que l'impact par rapport à du pur natif YAML est négligeable.

    Un truc tout con à faire qui aide beaucoup avec Node Red d'ailleurs : Tu fous un noeud qui récupère toutes les infos "state changed" dont tu balance l'output sur du debug. Comme ça tu vois en temps réel ce qui se passe.



    -----------
    Et d'un point de vue global, la logique "informatique" derrière la domotique, c'est de la gestion d'état. Soit tu le récupères toi même, soit il est push (le cas de capteurs de présence par exemple). Ensuite, tu réagis aux états des entités en y collant ta logique et tu en définis de nouveaux.
    C'est pour ça que j'insiste toujours lourdement sur le terme d'entité. Une ampoule ou un inter c'est exactement la même chose. L'état de l'inter va permettre de définir l'état de l'ampoule.
    Et de la même manière, l'état de l'ampoule peut servir à définir l'état d'une prise commandée.

    Un exemple con avec mon multiroom : J'ai bidouillé une vielle radio pour y foutre un pi zero et un ampli. L'ampli noich' de merdre provoque un souffle dégueu quand le pi ne balance pas de son.
    J'ai donc intercalé une prise commandée sur l'ampli.

    En domotique, le fait que le mediaplayer de ce Pi Zero soit mute/unmute commande directement la prise de l'ampli. C'est la relation logique entre ces deux entités.
    Derrière, il y a plein de manières de mute/unmute le Pi : Télécommande, interface, minuterie (sleep/radio-réveil)...

    Bref, OSBLC que ce soit une ampoule, un switch ou la température extérieure... Tout ça ce sont des entités avec différentes capacités (la norme zigbee veut qu'elles les diffusent) et différents états que tu gère avec ton soft domotique.




    Et ouais c'est assez fun d'interagir programatiquement avec son environnement quotidien.
    D'ailleurs, j'ai un souci mineur (et un peu la flemme) sur la détection de ma présence à la maison.
    Je m'en sert pour ne pas m'emmerder à couper la zik ou les lumières en partant. Dès que je ne suis plus là, zoup interruption de l'image et du son. Quand je reviens, il me refous la zik (y'a d'autres trucs pour les lumières).
    Pour ça, j'utilise le tracker de base : Mon téléphone est connecté ou pas au WiFi (soit à la base soit au satellite).

    Sauf que... C'est pas hyper fiable. Si je redémarre mon tel ou s'il perd le WiFi, c'est comme si je partais de la maison. Plus de son, plus d'image...
    Y' a des canards qui utilisent d'autres trucs pour se "géolocaliser" ?
    Dernière modification par Daedaal ; 17/01/2020 à 13h58.
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  22. #562
    Après avoir de nouveau appairé le switch au pont, ça marche niquel. J'espère que j'aurais juste pas à refaire la manip d'appairage trop souvent :D
    Les perfs, je m'en fiche un peu pour le moment, vu que j'ai 3 automatisations qui se battent en duel sur un Pi 4, certes je veux que ça soit réactif, mais c'est pas vraiment un sujet. En tout cas ça a l'air vraiment puissant NodeRed, clairement si je veux faire un truc poussé ou quand j'aurais un tas de devices, je me pencherai dessus !

    J'ai hâte de recevoir mon relai pour tester avec mes plafonniers et commencer à faire des scènes un peu soignées, mais le cargo depuis la chine c'est pas rapide rapide comme livraison...
    Citation Envoyé par Arteis Voir le message
    scie pieds sous terre

  23. #563
    Citation Envoyé par scie_sauteuse Voir le message
    Après avoir de nouveau appairé le switch au pont, ça marche niquel. J'espère que j'aurais juste pas à refaire la manip d'appairage trop souvent :D
    Les perfs, je m'en fiche un peu pour le moment, vu que j'ai 3 automatisations qui se battent en duel sur un Pi 4, certes je veux que ça soit réactif, mais c'est pas vraiment un sujet. En tout cas ça a l'air vraiment puissant NodeRed, clairement si je veux faire un truc poussé ou quand j'aurais un tas de devices, je me pencherai dessus !

    J'ai hâte de recevoir mon relai pour tester avec mes plafonniers et commencer à faire des scènes un peu soignées, mais le cargo depuis la chine c'est pas rapide rapide comme livraison...
    YES ! Content que ça ait fini par fonctionner (ça me donne espoir que ma telco hue finisse par marcher).
    Pas d'inquiétudes sur l'appairage, je n'ai eu à le refaire que quand j'ai reset l'un ou l'autre pont. Au quotidien ça roule.

    Un conseil... Passe sur NodeRed tout de suite si tu envisages un peu plus que des trucs basiques. C'est beaucoup plus clair (pour moi), et tu ne perdra pas de temps. Parce que tu passera à plus d'entités.

    Tu parles déjà de scènes... Imagine comme c'est simple de dire que tu veux que ton éclairage suive la température ou l'heure de la journée...
    Ou les deux. Selon qui est à la maison...
    C'est aussi simple que d'ajouter une condition "if then else". Peut-être qu'il te faudra un capteur noich' à 10 balles, mais quel pied de ne pas allumer la lumière dans les chiottes et de savoir qu'elle ne va pas te tuer les yeux en pleine nuit...
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  24. #564
    Citation Envoyé par Daedaal Voir le message
    Sauf que... C'est pas hyper fiable. Si je redémarre mon tel ou s'il perd le WiFi, c'est comme si je partais de la maison. Plus de son, plus d'image...
    Y' a des canards qui utilisent d'autres trucs pour se "géolocaliser" ?
    Tu peux pas foutre un systeme de buffer ? Genre il coupe tout a partir du moment ou tu cesses d'être connecté pendant plus d'une minutes.

    Sinon, https://gladysassistant.com/fr/artic...-cle-bluetooth
    Ce qu'il faut savoir, c'est qu'on ment beaucoup aux minmatars, surtout lorsqu'ils posent des questions du style: "t'es sûr que ça vole, ce truc ?" Cooking Momo, le 30/08/09

  25. #565
    J'ai eu de gros soucis d'instabilité du réseau Zigbee depuis midi, tout coupait tout le temps, c'était le bronx... du coup j'ai déplacé le Pi à son emplacement définitif dans mon tableau technique, branché directement sur le switch Ethernet qui dessert tout l'appart, avec une rallonge pour sortir le dongle de la boite métallique. Depuis, plus de soucis.

    Par contre ce que je m'explique moins, c'est pourquoi les boutons de mon switch Aqara apparaissent "indisponibles" dans Home Assistant, alors que le niveau de batterie remonte bien et que mes automatisations configurées dessus fonctionnent quand même ?!

    Un des prochains trucs prévus, c'est effectivement un détecteur de mouvement + ampoule dans les chiottes qui s'allume en rouge la nuit et en plus brillant le reste du temps. Ca, finir de connecter toutes les lampes de la pièce principale pour pouvoir activer facilement un mode "film" par exemple, et mettre en place un éclairage qui réagit à la lumière du jour dans mon bureau aussi. Ca va déjà bien m'occuper !
    Citation Envoyé par Arteis Voir le message
    scie pieds sous terre

  26. #566
    Citation Envoyé par Teocali Voir le message
    Tu peux pas foutre un systeme de buffer ? Genre il coupe tout a partir du moment ou tu cesses d'être connecté pendant plus d'une minutes.

    Sinon, https://gladysassistant.com/fr/artic...-cle-bluetooth
    Tu penses bien que je l'ai déjà fait. Mais il arrive (0.001%) que ça foire. Donc forcément je rage.
    Comme je n'ai pas envie de transiter par une app quelconque et abdiquer le peu de vie privée qu'il me reste... Je vais foutre une géolocalisation sur mon tel et sur la bagnole. En push (si je bouge j'envoie) si je trouve. J'ai déjà un localisateur GPS (de merde). C'est bidouillable.

    Si les deux sont dans un rayon de 10m de l'appart... C'est que je suis à la maison.
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  27. #567
    Citation Envoyé par scie_sauteuse Voir le message
    J'ai eu de gros soucis d'instabilité du réseau Zigbee depuis midi, tout coupait tout le temps, c'était le bronx... du coup j'ai déplacé le Pi à son emplacement définitif dans mon tableau technique, branché directement sur le switch Ethernet qui dessert tout l'appart, avec une rallonge pour sortir le dongle de la boite métallique. Depuis, plus de soucis.

    Par contre ce que je m'explique moins, c'est pourquoi les boutons de mon switch Aqara apparaissent "indisponibles" dans Home Assistant, alors que le niveau de batterie remonte bien et que mes automatisations configurées dessus fonctionnent quand même ?!

    Un des prochains trucs prévus, c'est effectivement un détecteur de mouvement + ampoule dans les chiottes qui s'allume en rouge la nuit et en plus brillant le reste du temps. Ca, finir de connecter toutes les lampes de la pièce principale pour pouvoir activer facilement un mode "film" par exemple, et mettre en place un éclairage qui réagit à la lumière du jour dans mon bureau aussi. Ca va déjà bien m'occuper !
    Zigbee est un protocole mesh. Chaque récepteur est aussi relais du signal. Donc tant que ton pont a un point d'entrée, normalement tu n'as pas vraiment de problème de portée (à échelle européenne des habitations). Il y a cependant des limites par canaux et j'ai lu des mecs ayant besoin de répéteurs, mais je n'en ai entendu parler que pour des installations sur des 1000/2000m².

    L'indisponibilité dans l'interface d'hassio ne veut pas dire que ton entité n'est pas là. C'est fonction du rafraîchissement d'hassio, des intégrations et de ton pont. Et de la mécanique interne d'hassio.
    Je commande des entités via NodeRed qui n'apparaissent pas dans hassio (mais leur batteries si... aussi...). Pire, j'ai déjà attaqué directement le REST d'un pont pour intégrer une entité.

    Je recommandais plus haut de passer sous NodeRed, ne serais-ce que pour ça. Tant que tu connais le nom/UID de ton entité, tu crée ta commande. Que l'interface d'hassio voie l'entité ou pas. Installe le et capte tous les events en debug. Tu devrais voir ton switch.


    Et pour l'éclairage nocturne, je ne saurais trop recommander "Circadian Lighting" qui est dispo en installant HACS (Home Assistant Community Store).
    HACS c'est un store communautaire un peu plus ou moins complet que les repositories habituelles. Mais qui contient son propre mécanisme de MàJ des plugins.
    Tu vas y trouver une masse de plugins, dont celui dont je parlais qui adapte la lumière (teinte et/ou chaleur et/ou intensité) à ton rythme circadien en tenant compte de ta position géographique et de l'exposition solaire correspondante.
    Dernière modification par Daedaal ; 17/01/2020 à 19h53.
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  28. #568
    Et pendant que je le fais, ne JAMAIS négliger l'impact d'une mauvais alim sur le Pi qui sert de serveur. Ni son refroidissement (ça c'est pour les perfs).
    L'alim conditionne aussi le fonctionnement d'un pont (USB ou HAT) qui serait sur le Pi...
    Si ça ne marche toujours pas... Prend un plus gros marteau !
    Citation Envoyé par Daedaal
    Je crois que je cite.

  29. #569
    Et avec encore un peu de bidouille, j'ai réussi à commander tout ça par Google Assistant. Ca commence à prendre forme !

    Pour l'instabilité du réseau je pense qu'un truc s'était mis en vrac dans Hassio ou le pont et que le reboot a résolu. Mais au moins, maintenant, c'est installé proprement. Niveau température du CPU, je la monitore dans un sensor Hassio, elle s'est stabilisée à 52° environ.

    Je note pour Circadian Lighting
    Citation Envoyé par Arteis Voir le message
    scie pieds sous terre

  30. #570
    Citation Envoyé par scie_sauteuse Voir le message
    1/ Hors de question que le net soit nécessaire pour allumer la lumière (par exemple, mais c'est valable pour tout), et si je peux éviter que mes datas se baladent dans la nature je préfère
    Mais...quelles datas? C’est juste des lampes, y'a pas de données perso.

    Suffit juste de pas linker à l’extérieur (pas créer de compte quoi, et encore encore une fois y'a tellement rien de privé à par la couleur choisie ou l'heure où tu as allumé ou éteins, comparé au spyware Google Home c’est peanut)).

    Mais c'est dommage, le compte HUE permet d'utiliser le LAB je crois.

    2/ Je veux conserver des boutons physiques pour la lumière histoire que des invités, ou moi en pleine nuit pas réveillée, soient capables d'allumer la lumière sans smartphone ou devoir gueuler sur google.
    En vrai parler à Google c’est marrant 2 jours (et en + pour le coup c’est horrible niveau vie privé, c’est Google qui a un micro ouvert chez toi 24/7, y'a pas pire, je l'ai même viré de mon smartphone ce truc), perso je fais tout au smartphone où aux interrupteurs physique. J'aime bien ceux aimanté là. Y'a aussi des détecteurs de mouvement, pratique pour la chambre ou la SDB, les couloirs, toilettes. Y'a un nouvel interrupteur qui est sorti aussi mais pas testé.

    Donc :



    Ca se place où tu veux vu que c’est sans fil, par contre du coup faut cacher les anciens interrupteur. Tu peux aussi les couvrir (les anciens) :




    En fait ces interrupteurs sont aussi des télécommandes (et c’est le bien ça) donc ils sont amovible (faut juste pas les perdre, mais au pire on sort son smartphone).




    En parlant de smartphone, tu peux mettre des interrupteur dans la barre des notifs pour des accès rapide aussi.
    En fait tu peux faire ce que tu veux, donc c’est à la fois un peu le bordel au début pour bien réaliser tout ce qui est possible, puis du bonheur une fois que tu commences à gérer. Genre tu peux faire plusieurs ambiances, mettre jusqu'à 5 ambiances par interrupteur, tu peux utiliser l’interrupteur de l'entrée pour allumer et éteindre TOUTE la maison, mais aussi ,ne lui faire allumer et éteindre que sa propre pièce, tout en rajoutant 5 ambiances, et en lui permettant de DIM al lumière, propre quoi, alambiqué au début, mais propre une fois en place.


    hors de question que je remplace chaque ampoule par du connecté. Ca va me coûter un bras et être une horreur à paramétrer.
    Coûter un bras oui. Une horreur à paramétrer, disons que si t'aimes paramétrer ça va


    Pour le reste oui t'es pas partie pour faire le plus simple, tu aurais ptet dû rester que sur du osram, du moins au début le temps d’être un peu plus à l'aise.
    Mais bon maintenant que tu y es plus trop le choix, donc, je connais mal mais je pense que tu devrais ptete regarder du coté de Jeedom, d'abord sur un ordi pour tester, et si ça te plaît acheter un Pi pour ça.


    https://www.jeedom.com/site/fr/

    - - - Mise à jour - - -

    Un des prochains trucs prévus, c'est effectivement un détecteur de mouvement + ampoule dans les chiottes qui s'allume en rouge la nuit et en plus brillant le reste du temps
    Yes j'ai fais pareil, j'ai mis rouge 1% de luminosité (sur les ampoules c’est suffisant), et aussi pour les ampoules de la chambre (comme ça ça casse pas les yeux), de 23h30 à 7h du mat.

    J'y pense je vois que tu as déjà un Pi, tu as du y ajouter un module Zigbee je suppose?

    - - - Mise à jour - - -

    Citation Envoyé par Daedaal Voir le message
    Zigbee est un protocole mesh. Chaque récepteur est aussi relais du signal. Donc tant que ton pont a un point d'entrée, normalement tu n'as pas vraiment de problème de portée (à échelle européenne des habitations). Il y a cependant des limites par canaux et j'ai lu des mecs ayant besoin de répéteurs, mais je n'en ai entendu parler que pour des installations sur des 1000/2000m².
    Si t'as un étage aussi apparemment parfois. (enfin murs ou dalle très épaisse qui isole le signal)

Page 19 sur 22 PremièrePremière ... 9111213141516171819202122 DernièreDernière

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •