PDA

Voir la version complète : probleme de son sous linux



elpaulo
15/10/2006, 03h54
Salut a tous,

Alors la c'est super bizarre :

1 : j'ai du son uniquement quand j'ai un casque ou un 2.1 branché sur la sortie casque
2 : le son est horriblement faible, je suis obligé de monter le volume de mon 2.1 a fond pour entendre pratiquement rien.
3 : dans le mixer par défaut de ubuntu, il me propose 2 carte son :wacko:

quelques infos : je suis sous Ubuntu et j'ai une carte son realtek. Ah oui c'est un ordinateur portable aussi.

Merci d'avance si vous avez une solution a ce probleme qui pue. :(

ducon
15/10/2006, 08h53
Montre le résultat de lsmod|grep snd.
Regarde aussi si dans le mixer tu n’as pas coché ou décoché quelque chose qu’il ne fallait pas.
Regarde aussi dans le BIOS si en effet, tu n’as pas deux cartes son.
Enfin, peut-être que la bonne sortie est une autre sortie. Par exemple, chez moi, je n’utilise pas les sorties normales (selon la documentation de ma carte mère).

elpaulo
15/10/2006, 12h59
je vais regarder tout ca, merci ducon (j'aurais jamais pensé dire ca un jour !).

donc :

ta commande me renvoie ca :


snd_hda_intel 18964 2
snd_hda_codec 157616 1 snd_hda_intel
snd_pcm_oss 53664 0
snd_mixer_oss 18688 2 snd_pcm_oss
snd_pcm 89864 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 25220 1 snd_pcm
snd 55268 8 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_ oss,snd_pcm,snd_timer
soundcore 10208 2 snd
snd_page_alloc 10632 2 snd_hda_intel,snd_pcm


ensuite, dans le mixer, j'ai tout essayé pour voir si ya du changement, j'ai meme installé plusieurs mixer pour voir, ca change rien.

dans le bios, une seule carte est détectée.

Pour ce qui est des sorties, de toute facon ya une sortie casque, une entrée ligne et une entrée micro (classique quoi) donc j'ai trop d'alternatives.

Merci, j'espere qu'avec tout ca tu pourra m'aider.

et au passage, y'aurais pas moyen de déplacer le sujet dans systèmes d'exploitation ? je me suis trompé en postant ici.

ducon
15/10/2006, 13h49
Je ne peux pas déplacer le sujet, je ne suis pas modérateur.
Tu sembles avoir les modules qui vont bien.
Regarde si tu as esd (ou artsd) qui tourne, et si oui, bute-le sans merci. Empêche-le aussi de revenir, en allant faire un tour dans le configuration de GNOME (ou de KDE).

elpaulo
15/10/2006, 13h56
Je ne peux pas déplacer le sujet, je ne suis pas modérateur.
Tu sembles avoir les modules qui vont bien.
Regarde si tu as esd (ou artsd) qui tourne, et si oui, bute-le sans merci. Empêche-le aussi de revenir, en allant faire un tour dans le configuration de GNOME (ou de KDE).


je suis novice en la matière, tu peux m'expliquer comment faire ca ? précision je suis sous GNOME.

ducon
15/10/2006, 14h02
killall esd, et ensuite lance le configurateur de GNOME, ou carrément gconf.

elpaulo
15/10/2006, 15h31
toujours pareil, volume ultra faible...

ducon
15/10/2006, 15h35
Il y a peut-être un volume planqué dans un coin et qu’il faut monter (du genre IGAIN).
Lance une application qui fait du boucan à partir d’une console X (gnome-terminal par exemple) et regarde si ça cause.

elpaulo
15/10/2006, 18h36
:( toujours pareil, je désespère...

Eld
15/10/2006, 18h41
tu lances alsamixer dans une console et tu mets tout au maximum avec de la musique en train de jouer, comme ça tu verras lequel a une influence :)

elpaulo
15/10/2006, 18h58
déja fait, tout est a fond

Daeke
16/10/2006, 10h11
et au passage, y'aurais pas moyen de déplacer le sujet dans systèmes d'exploitation ? je me suis trompé en postant ici.
C'est fait.

Sinon pour ton problème, j'ai le même sur mon portable donc si quelqu'un trouve, ça m'intéresse aussi.

elpaulo
16/10/2006, 11h49
ok merci de l'avoir déplacé, on aura peut etre un peu plus de réponses ici. ;)

ducon
16/10/2006, 20h46
Si Daeke a aussi le même problème, c’est peut-être un problème de pilote (de module du noyau, peut-être qu’il faut lui donner une option à la con, du genre IRQ), ou alors de bugue de distribution. Êtes-vous allé voir le site d’ALSA ou celui de votre distribution ?