Crunchez vos adresses URL
|
Rejoignez notre discord
|
Hébergez vos photos
Affichage des résultats 1 à 20 sur 20
  1. #1
    Hello,

    Memtest86+ is running with an Intel Prozessor Core i5-4440 3,1GHz 6MB Cache using 4 cores.

    Memtest86+ is freezing while running test #7. Why?

    Please help me.

    Picture from the freezing:

    PICT0002.jpg

  2. #2
    I confirm that MemTest86+ v5.01 fails on Test 7 on the following configurations:

    - Intel Core i3 3420 (I tested on two different Core i3 3240 CPUs)
    - two AsRock H77M motherboards (Socket 1155, Intel H77, DDR3)
    - one MSI H77MA-G43 motherboard (Socket 1155, Intel H77, DDR3)
    - one AsRock Z68 Pro3 motherboard (Socket 1155, Intel Z68, DDR3)
    - 2x 8GB GSkill Blue DDR3-1600, CL9-9-9-24, 1.5V Dual Channel memory kit
    - 2x 4GB Kingston Hyper-X DDR3-1600, CL9-9-9-24, 1.65V Dual Channel memory kit

    I have upgraded (and later downgraded) BIOS on first three motherboards trying to rectify issue but it did not help at all. During the test BIOS is set to default.

    And regardless which one of the two Core i3 CPUs I use on any of the four motherboards listed above with any of the two Dual-Channel memory kits (in Dual-Channel mode only!) when two identical RAM modules installed and "F2 - All Cores" option is selected MemTest86+ always fails on Test 7 - see the photo attached.

    However, in Single Channel mode any of the Core i3 CPUs on any of motherboards with any RAM sticks work ok. Also MemTest86+ gets passed by any of these two Core i3 CPUs successfully if "F1 Fail-Safe" or default mode (without pressing any key and letting to run automatically) are selected.

    And if I use Core i7 2600K with Dual-Channel kit then MemTest86+ runs for over 4+ hours without errors on any of the four motherboards and any RAM kits.

    Thus I think the motherboards and RAM kits can be cleared here since they all work fine with Core i7 2600K CPU. The issue seems to be limited only to CPUs or MemTest86+ itself. But I cannot believe that both Core i3 3240 CPUs are affected with exactly same fault. It is more likely that the issue is with MemTest86+ v5.01.

    For some reason one of the two Core i3 CPUs caused occasional BSODs on my main Windows 7 PC, that I had no problems for the last year, while another Core i3 worked flawlessly. Core i7 2600K has worked like a charm for over two years now passing all tests and I run games on it too without any issues. I think dissembling and reassembling Core i3 "under suspicion" and refitting its cooler could address the issue with BSOD. While this unlikely can fix the issue with MemTest86+.

    Also I run MemTest86 v4.3.6 (by PassMark Software) today on both of Core i3 3240 CPUs with Dual-Channel RAM kit and the test got passed for over 2+ hours after which I was stopping it as successful. I am running now Prime95 on the second Core i3 CPU (the one which is not "under suspicion") for over an hour and so far so good - no issues.

    Is it a "bug" with MemTest86+ v5.01? I noticed that option "F2 All Cores" is experimental which could explain why I keep getting this issue only in this mode.

    IMG_2120_MemTest86Plus_error_small.jpg
    Dernière modification par elny16 ; 22/11/2013 à 01h17. Motif: more information

  3. #3
    I can confirm that MemTest86+ v5.01 worked OK using all 4 cores (8 threads) on one of the following configurations for me (11+ hours without issues):

    Intel Core i7-4770K Socket 1150
    Gigabyte GA-Z87-HD3 (Socket 1150, Z87, DDR3)
    4x 4GB GSkills DDR3-1600 CL10-10-10-27, 1.5V

  4. #4
    Memtest86 5.0 Experimental UEFI Beta worked just fine with 4 cores on my system. I believe that Memtest86+ 5.01 has a problem with some systems.

    Memtest86 5.0 Experimental UEFI Beta is sleeping if temperature is too high, while Memtest86+ 5.01 is freezing.


    Memtest86 5.0 Experimental UEFI Beta:

    PICT0002.jpg

    All 4 cores are in wait state because of temperature but continue to work after the sleeping time elapsed.

    PICT0005.jpg

    PICT0006.jpg


    Memtest86+ 5.01:

    Core 3 is going to wait state and Memtest86+ 5.01 is freezing.

    PICT0002.jpg
    Dernière modification par ZYifJpiY ; 24/11/2013 à 16h40.

  5. #5
    I've been getting this issue too. It seems to create some sort of lockout on some CPUs as that is one of the few tests that can run full parallel.

    I found switching the SMP mode to Round Robin prevents the issue, and still gains significant speed advantages over single processor mode. (Just not quite as fast)

  6. #6

  7. #7
    Confirming freeze in test #7 in SMP mode with AMD Phenon II x3 on MSI 760GM-P23FX motherboad!

  8. #8
    I can confirm this issue on ASUS M5A97 board with AMD Phenom II x4 with UEFI

    Also on ASUS P5Q deluxe with Q6600 with legacy Bios.


    The cpu cores 0 1 2 were working in sync but core #3 was slower then the rest and then shows a W when it freezes on Block move test which is test #7.

    The system is totally locked up too no menu options work also.


    This only happens in SMP mode the fail safe mode seems to be just fine.

  9. #9
    Hate to rez an old thread, but is the multi core function in 5.01 just buggy?

    I can run memtest on a single core for like 3 hours straight and pass every single test. When I use the multi-core function it freezes at the exact same time on pass #7 [block move] every single try. The 4th core is stuck on W permanently.

    Specs if it matters:
    ASRock Z68 Extreme 3 Gen 3
    Corsair Vengeance 8GB (4x2) 1600 Mhz 9-9-9-24
    i5 2500k

  10. #10
    Citation Envoyé par creatinejungle Voir le message
    Hate to rez an old thread, but is the multi core function in 5.01 just buggy?

    I can run memtest on a single core for like 3 hours straight and pass every single test. When I use the multi-core function it freezes at the exact same time on pass #7 [block move] every single try. The 4th core is stuck on W permanently.

    Specs if it matters:
    ASRock Z68 Extreme 3 Gen 3
    Corsair Vengeance 8GB (4x2) 1600 Mhz 9-9-9-24
    i5 2500k
    I have the same problem.. My setup, in case it helps:

    Supermicro Server board X9SRI-F
    PROCESSOR: XEON Processor (E5 2609 v2)
    MEMORY: Hynix ECC RDIMM DDR3 PC3-14900 8x2GB (HMT325R7CFR8C)

  11. #11
    Attaché de presse
    Ville
    Houston, Texas USA
    I have also experienced the MemTest86+ v5.01 freeze in Test #7 (apparently at the exact, same point each time) when running in SMP mode on the following (similar) configurations:

    - Intel Core i3-4330 (happens on three separate Core i3 4330 CPUs)
    - ASUS Z87-A motherboard (happens on three separate Z87-A M/Bs)
    - 2x4GB and 4x4GB GSkill F4-14900CL9-4GBXL DDR3-1866, clocked at either 1600 or 1866 (happens in all combinations [that I tested] of the 14 sticks I have available, with either two or four sticks installed in each instance)

    When NOT running in SMP mode, the systems run for more than 24 hours without Memtest86+ reporting any error. Installing and running Windows 7 Pro SP1 on these systems does not result in any failures of any type.

    However, when running in SMP mode, the freeze happens the very first time, just a few minutes into the test, apparently at the exact same spot in Test #7 [block move]. The core state indication is "|||W", and Memtest86+ is unresponsive, such that the PC has to be physically powered off.

    If I transfer these memory modules into another PC (different motherboard and CPU), Memtest86+ reports no errors and there is no freeze.

    This freeze in Test #7 does NOT occur in any of these motherboards (or others, for that matter) when using an Intel Core i7-4770K. I would have tested a Core i5, but I don't have a free one handy at the moment. Clearly, this freeze in Test #7 is a problem with the Intel Core i3-4330 CPU, Memtest86+ itself (when using more than one "core"), or the Intel Z87 chipset (or the combination of the i3-4330 and the chipset).

    Since my purpose in using Memtest86+ was to validate the reliability of these new DDR3 memory sticks, I can't complain much; their tests run without error, both at nominal speed and overclocked, using just one i3 core on these systems, and in SMP mode on other systems, and in SMP mode on these systems with a much faster Core i7 CPU. The sticks are good. So I will just have to remember that Memtest86+ fails on Intel Core i3 CPUs (at least in an ASUS motherboard with an Intel Z87 chipset).

    I will run more tests on other motherboards (Z87, et al.), including some with i5 CPUs, when I can get to them. I mostly have i7 CPUs available; this was the first batch of i3 CPUs that I have used in systems I've built.

  12. #12
    Some relief for me reading this thread started way back in 2013. I was thinking problem with PC seeing 5.01 been out so long. I put known RAM 2x 4GB in dual channel works without error NOT running SMP. Test #7 problem with SMP causes PC to reboot. I was just well into Test #5 (12 cores / 12 active) and same thing.

    I am not looking for answer now, my answer is not to use memtest86+ 5.01.

    I am not even sure of the single channel testing I did using 5.01 non-SMP that showed 3/4 sticks in the originally installed Corsair Vengeance CMZ32GX3M4A1600C9 is accurate. Back to the drawing board for me.

    MSI X79A-GD45 (8D) Uefi
    I7-3930K
    32GB DDR3 Quad channel

  13. #13
    I'm experiencing the same issue, doing the block transfer test (Test #7), on an Intel i5-4570 CPU, Asrock B85M PRO4 m/board, and 4 x 8GB Kingston Hyper Genesis DDR3-1600 chips, running at default timings (reported as 11-11-11-28). It locks up about 27% of the way through test #7, when using all cores simultaneously.

    Running test #7 on a single core works.

    memtest86 5.1 UEFI (which I realise isn't memtest86+) completes 4 passes without errors.

  14. #14
    I can confirm this on Core2 Duo, Memtest86+ 5.01. Freezes with a static line and a W. A couple other reports of this:

    http://www.sysnative.com/forums/hard...memtest86.html
    http://forum.thinkpads.com/viewtopic.php?f=18&t=112226

    The first link seems to suggest that it can be ignored. But I'd still love to hear an answer, if there is one.

    And if anyone wants to hear a funny n00b story: it took me three tries to register on these boards. The first two verification questions were "canard ??". I first assumed it must be French, judging from the other forum sections, and answered "duck". The second time it came up, I spent a good couple minutes trying to think of a response to the English meaning, "false story ??" I considered "No.", but eventually just typed in "canard". It wasn't until the third question, "World of ???craft" that I figured out what was going on. Talk about overthinking!

  15. #15
    The SMP mode is experimental.

    I had the same issue on my AMD CPU. I simply ran in round-robin or uniprocessor mode to fix the issue.

    Try switching it to round robin instead of all cores or just turning off SMP. That worked for me.
    Dernière modification par Ruedii ; 09/07/2014 à 02h13. Motif: More detail about personal experience.

  16. #16
    I had the same issue with my i7-5820K, 2 corsair 2400mhz (16gb total) modules (not dual chan.)
    At #7 the pc would automatically reboot using 12/12 cores. When running in fail safe with only one core it works fine.
    At first i was afraid there was something wrong with my system. Untill, gladly, i read this forum

  17. #17
    Same here with 5.01 on Intel Core i5 6400 on Gigabyte GA-H170-HD3 with 2x Kingston DDR4 8 Go HyperX Fury 2133 MHz CAS14.

    Consistent failure, with SMP on, on test #7 at 44% with 2 modules, at 68% with 1 module no matter which.
    No failure without SMP - much slower though.

  18. #18
    seeing something similar on a Lenovo g570
    2520m and b800 cpu's.
    only happens in multi core mode (round robin/sequential runs fine) with dual channel memory (2 sticks) (128bit mode) a single module passes ok.

    I've got 3 modules, a 2gb, and a pair of 4's
    might be related to having more then 4gb of ram rather then more then 1 module but I don't have a 2nd 1 or 2gb module to test that theory.

  19. #19
    I do have the same problem on two identical machines when running memtest86+ (version 5.01) in SMP mode enabled and all cores (parallel mode). I am using memtest86+ (version 5.01) from ubuntu-16.04.1-desktop-amd64.iso image. There is no issues (after about 24 hours of testing) in sequential or round robin mode, or when using single core.

    It always stops at the same time, around 5 minutes, when last core in 'W' state in test 'moving blocks' around 4-8G region.

    My machine is Zotax ZBOX CI323 Nano, with 2x8 GB of Kingston HyperX . But it also happens with just one module used. The memory is not officially supported (it is not on the official list from Zotac, and the spec from Zotac and Intel claims max of 8GB can be used with this CPU - Intel(R) Celeron(R) CPU N3150 @ 1.60GHz , which is a 4 core CPU, with boost frequency, and often continuous operation of 2.08GHz, which brings it to 89 deg C. The memory do works without any issues in Linux tho, with many days of operation, and full memory tests done too.

    But more importantly, I am able to reproduce this problem under qemu emulator / virtual machine on a completely different physical computer which is working without any problems for past 4 years (Intel i7-3930K @ 4GHz water cooled to under 40 deg C, with 32GB of RAM in 4 DDR3 modules, I believe G.Skill TridentX 32GB DDR3 Kit)
    ).

    qemu-system-x86_64 -enable-kvm -m 8G -smp 3 -cdrom ubuntu-16.04.1-desktop-amd64.iso

    It doesn't happen with smaller number of processors than 3 (like -smp 2), but it can be more, confirmed to also crash with -smp 4 and -smp 6.

    It doesn't happen with less than 8G of ram, i.e. 1G or 4G doesn't crash. But 8G and 16G do crash.

    Example screenshot:



    I wasted something like 4 days of time trying to figure out what is wrong with my new second zotac box, as it was failing in the Debian testing installer with some segfaults, then found the crashes (it would halt) in memtest86 during SMP run. Only to eventually confirm this is not the problem with the machine, but the bug in the Debian new installer, and a bug in the memtest86+ making me chase wrong problem (hardware, instead of software).

    Please fix or remove this functionality. :/

    PS. Registering on this forum is a bit of a pain with security / anti-bot question having some French specific questions.

  20. #20
    Correction, it also freezes with just 2 cpus and even with just 6G of memory:



    It is probably some off-by-one bug in the synchronization code.

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •