Crunchez vos adresses URL
|
Calculez la conso électrique de votre PC
|
Hébergez vos photos
Page 9 sur 36 PremièrePremière 123456789101112131415161719 ... DernièreDernière
Affichage des résultats 241 à 270 sur 1072

Discussion: SSD et mémoire flash

  1. #241
    Citation Envoyé par adralac
    J'ignore si la carte raid possede sont propre cache,mais il me semble,cela dit ça nexplique pas tout a fait de telles variations!

    A priori ça vient de la taille des strips, qui foire avec la structure de la flash NAND (même taille de blocks, mais pas synchrone)

    Javais désactivé ma mémoire cache mais je commence a avoir de petit soucis comme nod32 kernel service qui plante.. (en plus jai que 512 de vive)...

    Quel est la meilleur méthode a adopter?
    1/ la réactiver;probleme de duré de vie ou légende urbaine?
    2/ la rediriger sur la mémoire vive elle meme,(voir meme sur une clé usb)
    et quel méthode utiliser pour la rediriger dans ce dexieume cas?

    La durée de vie, je ne sais pas vraiment. Techniquement, il y a pas mal de mesure de protection, et les constructeurs de SSD semblent assez confiants vu les MTBF (qui ne veulent pas dire grand chose, mais bon).
    Le seul truc, c'est que je ne suis pas certains du tout que ce genre de truc soit implémenté dans des cartes Compact Flash, à fortiori des cartes "grand public".

    Rediriger sur la mémoire vive : y a un driver pour XP embedded qui existe, (EWF filter). c'est utilisable en bidouillant sur un XP classique (j'ai plus les liens comme ça).

    Sur une clés USB : on a le problème que c'est un périphérique amovible, donc XP veut pas.


    __Derniers résultats de l'extremeIV__
    Reconnu en udma 2 par défaut mais forcé dans windows en udma 3,ça redémarre en udma 3!!! a croire qu'un flag udma2 est intégré dans son firmware!

    Peut-être, même si normalement, c'est des U-DMA4

    Sous hdtach:36.7mo/s en lecture moyenne , 0.4ms en temps d'accès aléatoire

    Normal, c'est ce qu'on obtient avec le lecteur FW de Sandisk (environ, ils annoncent 40)


    En revanche je ne parvient pas a booter sur une nappe 80pin(erreur de lecture au démarrage!)
    donc udma4 toujours pas accessible!)
    (je vait essayer de la forcé en udma 4 sous windows,et de booter sur une nappe 80 pin...sait on jamais!)

    La nappe est pas défectueuse ?


    _Edit:et non! toujours pas de boot possible sur nappe 80 pin !...

    Est-il possible que certains adaptateurs tel celui-ci: (CFADTCS-ROHS de MEZA pour CFtypeI&II)
    Ne supportent pas le boot sur 80 pin??? ou,en posant la question a l'envers:

    Quelqu'un parvient-il a booter sur du 80pin ???

    Je boote sur du 80 pin, automatiquement.
    Normalement, si l'adaptateur supporte le DMA, ça doit suffire (parce que tous ne le supporte pas).
    C'est quoi comme carte mère/chipset ? le contrôleur peut poser problème, de temps en temps (certains ont eu du mal sur les forums avec des nforce)

  2. #242
    c'est peut-être pour limiter le débit que la nappe de 80 fils ne passe pas...

  3. #243
    J'ai pour l'instant réactiver le cache disk,mais j'essayerais,voir ce que ça donne avec l'EWf filter,..

    La sandisk est effectivement Udma 4 normalement! donc je cherche toujours!

    J'ai essayé avec 2 nappes 80 pins différentes pour l'instant..chacune ne posant pas de problemes avec les autres dures ordinairement.

    Donc:
    a/comme tu parvient a booter automatiquement sur du 80 pins,
    b/et que mon adaptateur supporte le dma
    (2 jumpers pour ça sur l'adaptateur pour passer en NOR ou DMA),

    Cela pourait-il venir dun probleme de compatibilié du controleur IDE de la carte mère (abit AN7,basé sur chip nforce2 ultra) ??? (ce qui serait surprenant !)

    J'essayerais dès que possible sur asus A8N32 (chip nforce 4)...

    Ce qui est curieux c'est que norton ghost sous msdos,refuse lui meme d'effectuer un clonage vers la sandisk,lorsqu'elle est en 80 pins! : "erreur de lecture sur 64 secteurs"!
    Memes erreurs de lecture de la part de active killdisk!
    (quand a l'install de windows,elle plante au premier redémarrage...)

  4. #244
    Les nappes 40Pins sont UDMA33 max, donc UDMA-2.
    Mon nforce 4 ne supporte pas la compact flash sur 80pin, à moins de la mettre en PIO-Mode :/ Mais avec ma carte contrôleur hightpoint 370A, ça marche nickel avec une nappe de 80pins, mais comme j'avais une carte UDMA-2...

    Adralac, tu n'as pas d'autres PC où tester ? Tu as quoi comme controleur IDE ?

    Dandu : sympa le test

    Cordialement,

  5. #245
    Citation Envoyé par dandu
    Quelques tests en RAID

    1 : ça marche mieux avec deux cartes identiques (ça foirait à cause de ça).
    2 : que la carte soit fixed ou pas, ça change rien, ça donne un disque local en sortie (2 fixed, 2 removable ou 1 fixed et 1 removable)

    Question vitesse :

    1 carte : 16 Mo/sec via HD-Tach, 14 en lecture réelle, 11 en écriture réelle (en gros)
    2 cartes : 28/20 via HD-Tach (j''explique après), 24 en lecture réelle, 20 en écriture réelle (en gros aussi)

    j'ai travaillé avec du raid de base (strip de 64 Ko), sur une carte Promise (Fasttrak tx2000).

    J'ai juste un truc bizarre avec HD-Tach. D'habitude, on a une ligne droite, avec le burst équivalent à la moyenne sur la flash (pas de cache). Ici j'ai une autre forme :



    J'imagine que c'est la taille de stripe qui doit faire ça, je vais un peu essayer autre chose que 64 Ko.
    Essaie de tester avec Winbench99 (il ne teste que la lecture mais bon).

  6. #246
    Bon, réponse en vrac :

    j'ai testé sur du Sis, du Intel et du promise, pas nVidia.
    et sur le promise, une carte PIO passe pas.

    Marc : je vais essayer.

    Notez qu'en mettant le stripe sur 32Ko au lieu de 64 Ko, j'ai une ligne droite

    donc à priori, c'est la gestion de la nand en accès indirect qui pose problème

  7. #247
    Les nappes 40 pins vont jusqu'au UDMA 3 (44.4mo/s),non?

    en pratique,en UDMA 2(33.3mo/s),je plafonnait a 28.8mo/s ,
    a présent en udma3 jai 36.7mo/s,toujours en 40 pins (valeurs hd tach),

    donc proche des valeurs optimal de la sandisk et les apps se comporte déja mieux(carte tv,carte son),franchement instables en Udma2.

    C'est donc surtout pour la stabilité que jaimerais passer en 80 pins

    j'ai un controleur nvidia nforce2 ATA (V 2.6)

    mauvaise nouvelle car mon seul autre pc CM ASUS,a un controleur nvidia nforce4(pas testé encore)
    intéréssant,que ça marche via une carte controleur hightpoint en revanche!

    édit:
    merci pour ces éléments de réponses a propos de vos controleurs IDE compatibles ou pas 80 pins
    C'est intéréssant,mais aussi surprenant!, quelle pourait en etre l'explication?

    je continue a creuser,
    mauvaise détection automatique du bios;(l'extremeIV reconnu udma2,bien que passé sous win en 3 en 40 pins )donc corrigible dans une certaine mesure....
    peut-etre + en forçant certains parametres du bios non prix en compte par win au moment des premiers acces disque,...........ou limitation des controleurs?

    je vais aussi me faire préter un siriel(ide to s_ata) et tenter avec...!

  8. #248
    Citation Envoyé par dandu
    Notez qu'en mettant le stripe sur 32Ko au lieu de 64 Ko, j'ai une ligne droite

    donc à priori, c'est la gestion de la nand en accès indirect qui pose problème
    Une ligne droite avec quel débit ?

    Sinon je pensais que c'était UDMA33 le max, donc UDMA-2, le 3 étant un truck batard apperremment :/

    nForce 2 et 4, c'est le même contrôleur IDE, j'avais testé sur le nForce 2 aussi, mais pas sur mon autre PC en Via :/ faudrait que je récupère ma carte flash tiens ^^

    Le HighPoint marche nickel, mais légèrement moins bien en latence que le nForce, mais j'ai la même chose avec des disques durs :/ Surement car c'est une carte aditionnelle.
    Par contre le highpoint ne supporte que l'UDMA, rien d'autre. (je ne peux pas mettre de lecteur dvd dessus par exemple, mais normal c'est une carte pour le raid ^^ )

    Je me suis commandé une DS3, à la limite je vais retester dessus ^^ Mais j'aurais toujours le très gros problèmes d'avoir une Compact Flash avec une latence horrible :/ Et non fixed :/

    Dandu, as-tu effectué un test de petits fichiers avec et sans raid ?

    Cordialement,

  9. #249
    pour le moment, j'ai testé avec 1,2,4,8 et 16Ko de block.

    j'ai pratiquement à tout les coups une ligne droite à 29Mo/sec.

    le max en Compact Flash 3.0, c'est U-DMA4, le 66Mo/sec.

    pour le fixed ça s'arrange assez facilement chez Sandisk

    j'ai pas encore testé les petits fichiers, je regarde d'abord ou j'ai les meilleurs perfs.


    sinon, truc bizarre : en mettant les cartes en RAID1, j'ai 30Mo/sec en burst et 15Mo/sec en test classique via HD-Tach, c'est assez étonnant.

    et les blocks de 1024Ko, c'est pas génial, ça donne pas grand chose.

  10. #250
    Ok merci ^^
    Je pensais que se serait l'inverse, vut que la flash aime les gros fichiers ^^

    Le RAID1, c'est bizard oui :/ mais c'est peut être que pendant 0.1s il y a 30Mo/s, pendant le changement de carte.

    Avec 30Mo/s ça doit être sympa pour un windows non ? Saurais tu installer windows et tester PCMark03 (ou 05) dessus ?
    Je sais :/ là je t'en demande beaucoup ^^ Mais c'est un très bon test.

    Perso, j'ai ça avec mon DD :

    - 1 x 250Go SATA II

    System Test Suite
    HDD - XP Startup 8.62 MB/s
    Physics and 3D 178.8 FPS
    Transparent Windows Test failed
    3D - Pixel Shader 124.13 FPS
    Web Page Rendering Test failed
    File Decryption 48.91 MB/s
    Graphics Memory - 64 Lines 1184.27 FPS
    HDD - General Usage 5.57 MB/s
    Multithreaded Test 1 / Audio Compression 1592.07 KB/s
    Multithreaded Test 1 / Video Encoding 198.73 KB/s
    Multithreaded Test 2 / Text Edit 88.67 Pages/s
    Multithreaded Test 2 / Image Decompression 13.79 MPixels/s
    Multithreaded Test 3 / File Compression 2.55 MB/s
    Multithreaded Test 3 / File Encryption 14.36 MB/s
    Multithreaded Test 3 / HDD - Virus Scan 15.95 MB/s
    Multithreaded Test 3 / Memory Latency - Random 16 MB 17.52 MAccesses/s

    Donc c'est un test d'utilisation de tous les jours Mais je n'ai pas put tester sur ma flash vut qu'elle n'est pas fixed
    J'ai eut un peu pareil avec d'autres disques durs, et j'ai vut des résultats pas beaucoup meilleurs avec des raptor :/

    Cordialement,

  11. #251
    Pour la flash, c'est pas vraiment qu'elle aime les gros fichiers, c'est juste qu'un gros fichier masque la latence de la NAND.

    en gros : premier accès à un bloc, 25µs. accès suivant (si contigu), 0,03µs.
    si tu travailles avec beaucoup de fichiers, on change souvent de blocs, donc on se prend la grosse latence souvent, d'où perte en vitesse brute.

    C'est pire en écriture, vu qu'on doit rajouter 2ms de temps d'effacement du bloc.


    Pour PC Mark, je ne sais pas tester en RAID, c'est deux cartes de 1 Go. je vais essayer de retrouver mes fichiers de log quand j'avais essayé avec la carte industrielle.

  12. #252
    Ok Mais le raid divise par 2 tout celà, l'idéal est donc un split de la taille d'un block, mais je ne connais pas la taille :/ Mais ça doit être petit...
    J'avais peur que le raid fasse l'effet inverse, mais en faites non :P

    C'est bon tout ça ^^

    2Go ne suffit pas ? Tu as mis windows dessus pour voir ? ça réagit bien ? :P

    Par hazard, 2 compact flash non fixed le sont-elles une fois en raid ?

    Cordialement,

  13. #253
    en général, le block fait 128Ko (64 pages de 2 Ko), amsi sur les petites cartes ça varie.

    Windows, il faut un 4 Go.
    Sinon, ça régait très bien avec une carte industrielle en U-DMA4 (environ 20Mo/sec) mais c'est un rien lent en taux de transfert face à un disque dur quand même.

    Deux CF non fixed sont vues comme un disque classique en RAID, oui.

  14. #254
    Citation Envoyé par dandu
    Deux CF non fixed sont vues comme un disque classique en RAID, oui.
    :coeur:

    Sinon windows je l'ai déjà installé sur ma compact flash de 2Go, pas de probs :P Mis à part qu'ils mettait 10 ans à enregistrer à la fin vut la lenteur de l'éffacement/écriture :/

    Mais c'est quoi comme Compact Flash que tu as ?

    Merci

    Cordialement,

  15. #255
    Deux ExtremeIII d'1Go Sandisk

    Une passée en fixe, l'autre pas

  16. #256
    Et c'est quoi leur norme ? DMA multi-word ou de l'UDMA-X ?

    Merci

    C'est vrai qu'elles sont pas beaucoup plus cher que des transcend industriel fixed et UDMA.

    Cordialement,

  17. #257
    Citation Envoyé par Progerien
    Sinon je pensais que c'était UDMA33 le max, donc UDMA-2, le 3 étant un truck batard apperremment :/
    c'est effectivement un "truck batard" l'udma mode3 !,et wondows n'aime pas! c'est pas une norme pour HDD a lorigine...

    c'est dailleur pour ça quen 40 pin on est par défaut en udma33,et en 80 pins en udma 66 par défaut
    (en fasant plus attentiion a ma séqence de boot)

    l'extreme IV est bien reconnu en udma 66 au boot,puis vérifying dmi pool,update succesfull,
    Puis,"erreur lecture disk"... enfin,rageant et toujours inexpliqué a ce jour...

    qu'on intel et SiS que promise et Nvidia n'ont pas?

    interessant ça: CF amovible + carte raid = CF fixed!

    (oui,fixed disk s'arange bien sur sandisk extreme IV ,Manip faite sur nappe 40pins)

  18. #258
    Cool je viens de voir une Extreme IV 2Go, à 60€, c'est cher, surtout pour 2, mais bon... :P Ca me tente bien ^^

    nVidia ont des mauvais contrôleurs IDE. Promise, c'est comme highpoint, carte RAID, donc rien d'autre que du DMA

    Sinon, il éxiste des cartes controleurs RAID pas bien cher, genre 15-20€ En général c'est du Via dedans, ou du ITE.

    edit: maintenant qu'elle est fixed, ça rox sous windows ? :P même si c'est en UDMA33 :/

    Cordialement,

  19. #259
    j'ai vu extreme IV 4Go a 90 euros... peut-etre plus interressant?

    dès que je lai eu fixe,un clonage de ma partition system dessus,et elle a booter normalement..

    malgrès l'udma 33,on sen pas trop les ralentissement
    (surtout du a labsence de cache en écriture bien que win en détect un,que j'ai désactivé)

    mais cest un system lourd(6.5Go), et limite instable ,meme sur disk dure,que j'utilise,histoire de le mettre a rude épreuve:
    de fait l'usage de la carte tv engendre des saccades intolérables,et la carte son RME n'apprécie pas d'avantage...

    donc,avec un sys léger ça va ,mais faut pas en demander trop...

    un petit mieux en mode "batard" udma3, carte tv et carte son,fonctionnent sans saccades... pendant un moment... puis idem....saccades

    en fait,a chaque fois,cest windows qui me downgrade en mode PIO,en raison de trop nombreuses erreurs!!!

  20. #260
    Bah :/ ton windows il a besoin d'une réinstallation ^^
    Puis bon, un nForce 2... :/

    La compact flash de 4Go est plus intéressante au giga, mais après pas de raid :/
    C'est vrai qu'avec 2 de 4Go, je peux installer Vista dessus, pour plus tard, mais à 200€ je préfère un RAID de 3 DD de 250Go :/

    Menfin... j'ai d'autres priorités à acheter avant :P

    Cordialement,

  21. #261
    Citation Envoyé par Progerien
    Bah :/ ton windows il a besoin d'une réinstallation ^^
    peut-etre,mais comment peut-u l'affirmer ainsi,uch:
    a quoi bon tester un windows vide ?,tout propre tout nikel,

    alors que c'est le but me semble-til de tester son sys,quelqu'il soit,sur HDD et CF ,a l'indentique,avec le MEME windows donc,afin de pouvoir comparer objectivement...

    et objectivement,c'est pas ça pour mon system lourd,mais comme je l'ai stipulé avant,sur un win avec des apps peu gourmandes ,ça doit mieux passer...

  22. #262
    Bin c'est toi qui le dit :P

    mais cest un system lourd(6.5Go), et limite instable
    Qu'il soit lourd c'est quelque chose ^^ Mais instable :/

    Mais tu as tout mis sur la CF ? Même la mémoire virtuelle ?

    Et avoir des erreurs, c'est pas normal :/ Car une compact flash a un ECC intégré :/
    Donc tu dois surement avoir une ram capricieuse. (ou c'est le nForce 2)

    Et tu as les saccades de la carte TV avec le disque dur ?

    Cordialement,

  23. #263
    Citation Envoyé par Progerien
    Bin c'est toi qui le dit :P

    Qu'il soit lourd c'est quelque chose ^^ Mais instable :/
    limite instable,jai précisé, bien que prime95 et occt tiennent sur HDD ,chacun ça définition d'instable...
    selon l'emploi qu'il fait de sa machine


    Mais tu as tout mis sur la CF ? Même la mémoire virtuelle ? pas au début,a présent oui

    Et avoir des erreurs, c'est pas normal :/ Car une compact flash a un ECC intégré :/ savait pas
    Donc tu dois surement avoir une ram capricieuse. (ou c'est le nForce 2)
    de la corsair twinx cas 2.2.2.6
    prime95 et occt passent sans probleme,sur HDD... le nforce2 est pas terrible et c'est pas nouveau,
    MAIS,de maniere objective,sur HDD tout ce passe bien/CF !


    Et tu as les saccades de la carte TV avec le disque dur ?
    non

    Cordialement,
    Cordialement,adralac

  24. #264
    Et prime95 et OCCT passe avec la CF ??
    C'est bizard pour la carte TV, car normalement elle ne passe pas par le DD :/ Et si c'est le cas, ça veut dire que c'est un flux continue, donc mauvais pour la durée de vie de la compact flash.

    Mettre un windows d'un disque dur UDMA100 et +, sur une compact flash UDMA33, ce n'est pas le top :/
    Je pense qu'il vaudrait mieux un windows fraichement installé pour tester ça.

    Et il est aussi déconseillé de mettre la mémoire virtuelle sur la compact flash, ça réduit sa durée de vie, et elle est pas adapté à des lectures/écritures constantes de cache.

    Tu as pris la compact flash pour un gain de place ? Ou de performance ?
    Car une compact flash n'est pas du tout adapté pour de la vidéo, où c'est le débit qui prime :/

    Cordialement,

  25. #265
    J'ai pas encore lancé prime95 et occt sur la CF,mais je le ferait tout a l'heure pour voir..sans trop d'illusions..

    En fait c'est un pc pour faire du sound mastering,et les acces disques et parasites générés font monter le seuil de bruit,tant a lenregistrement qu'a l'écoute,sur une carte son RME 9632 hammerfull

    d'ou l'idée depuis longtemps de passer en dikless...ou CF ,
    or,mon seuil de bruit a diminuer de 12db environ.

    j'ai pensé a passé mon windows en udma33,avant de le cloner sur la CF en udma33, puis essayé sans,et c'est pareil...
    mais c'est clair qu'un windows fraichement installé sera plus stable.. base de registre plus propre,etc...,mais l'IDE sera til détecté différemment?

    ce qui est instable,c'est l'association de la carte tv et de la carte son pour des histoire de directx non supporté par la CS pas faite pour
    (windows indique"aucun périphérique audio")...
    donc pas mal de complications...
    et une syncro image/son précaire(faut pas que la carte tvtnt310i génères d'erreurs de flux,sinon cest la désinro assuré,et la mon windows sur CF ,me downgrade en PIO,alors que ce n'est pas le cas sur HDD,

    ou il suffit meme de réduire et ragrandir la fenetre de l'apllis video(cyberlink power cinéma),pour retrouver la syncro(plus possible sur CF,étant forcé en PIO,bien trop lent pour que l'applis tourne correctement..

    la stabilité du mode udma utilisé semble prépondérent... d'ou la recherche du mode udma66.

    j'essaiyerais EWF filter par la suite

  26. #266
    Perso, j'avais testé en copiant un windows sur la CF au début, bin c'était la merde :/

    Sinon, si tu as assez de ram, tu peux faire un ramdisk dans lequel mettre le temporaire windows et la mémoire virtuelle.

    Essaye de l'IDE nForce avec et sans les pilotes IDE, d'ailleurs les pilotes nForce 4 ont les mêmes pilotes IDE que le nForce 2, mais peut être plus récent :P Essaye toujours.
    Je me rappel que l'installation nForce demande si on veut activer le "IDE SW" mais je ne sais plus si c'est mieux avec ou sans :/

    Pour le bruit, la flash c'est le top :P Mais si windows la met en PIO... :/
    Au pire il y a toujours des cartes contrôleurs IDE pour pas bien cher, moi j'ai une Adaptec 1200A avec chipset HTP370A, et ça tourne nickel avec :P
    Enfin... après j'ai une CF à chier

    Le EWF Filter empèche d'écrire sur la CF, mais pour ce que tu fais, tu es obligé d'écrire dessus :/

    Cordialement,

  27. #267
    Citation Envoyé par Progerien
    Sinon, si tu as assez de ram, tu peux faire un ramdisk dans lequel mettre le temporaire windows et la mémoire virtuelle.

    Je me rappel que l'installation nForce demande si on veut activer le "IDE SW" mais je ne sais plus si c'est mieux avec ou sans :/
    Sous Windows, tu ne peux pas mettre la mémoire virtuelle dans un ramdisk.

    Sur nForce2 (et 4?), c'était mieux de ne pas installer ces driver.

  28. #268
    je vais commencer par revenir au pilotes IDE par défaut de windows alors!
    que j'ai très longtemps utilisé sans probleme,
    ayant activé le IDE SW pour justement l'essayer,depuis quelques mois..

    sans soucis,mais sait-ont jamais...

    je vient dessayer sur nforce4,de booter,idem nforce2 effectivement,NADA!

    pour la mémoire virtuelle,je suis dans le noir ,sans,ça marche pas,et avec ça craint pour la CF...

    edit:
    repasser sur les pilotes IDE de windows n'aide en rien malheuresement...
    il n'est plus possible de modifier le mode udma employé,mode2 udma par défaut..
    donc,les applis ne tournent pas correctement
    ce qui force windows a repasser immédiatement en PIO !

    bien plus vite qu'avec le IDE SW de nvidia,paramétré en mode 3,qui reste stable 1h ou 2! :whistle:

    OCCT 0.7 et 1.1.0 (test cpu et RAM)plantent a 3%,ce qui corespond a la minute en idle mode!,dès qu'OCCT commence a attaqué,il plante immédiatemment! du jamais vu!

  29. #269
    Citation Envoyé par Progerien
    Sinon, si tu as assez de ram, tu peux faire un ramdisk dans lequel mettre le temporaire windows et la mémoire virtuelle.
    :sarcastic:uch::whistle: par définition si tu as assez de RAM tu désactives le swap
    Keyboard error or no keyboard present
    Press F1 to continue, or DEL to enter setup

  30. #270
    Sauf que WindowsXP a besoin du swap. Meme si tu l'as désactivé, il t'en créera un.
    Créer un ramdisk pour y mettre le swap, ça parait un peu étrange, mais de toute façon c'est pas possible sous Windows.

Page 9 sur 36 PremièrePremière 123456789101112131415161719 ... DernièreDernière

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •