Crunchez vos adresses URL
Rejoignez notre discord
Hébergez vos photos
Affichage des résultats 1 à 2 sur 2
  1. #1
    Sorry I can only post in English as I don't speak French... I have a PC that I am trying to get running and eventually be a household server... I upgraded it to 48GB of RAM by adding 4x 8GB sticks to the 4x 4gb sticks it had when I got it. The memory is installed per Intel advice on keeping the same size stick in both slots of any given channel - so 8GB sticks in channels 1 & 2, 4GB sticks in Channels 3 & 4.

    The mobo is an Intel DX79-SR from around 2012, The CPU is a Sandy Bridge generation i7-3930K – 3.2 GHz/3.8 GHz Turbo Boost, 6 cores, 12 MB L3 cache, with hyperthreading that gives an effective 12 cores

    Both Memtest86+ and the free Passmark Memtest86 run in single core mode with no errors

    I am running Memtest86+ version 5.31b off a CD that I burned from the precompiled ISO off the main site. By default it boots and starts running on core 0 and says SMP disabled.

    If I press F2 to force SMP mode I get failures, the ones I have caught as they are happening consist of a black box opening in the middle of the blank part of the usual blue screen with yellow text.

    At first it says "Internal error *** line-169 test.c" and the test freezes. A minute or so later it adds "Internal error *** line 92 test.c". After another minute or so it adds "Internal error *** line 131 test.c" A little while after that the system reboots, and since I have it set to boot off the CD it starts Memtest86+ up again, but only in single core mode...

    Both times I caught the error it had been running for about 12 minutes, and was in test 3, with the memory line 2048M - 3256M 1208M of 48G, showing zero errors in the status window It appeared from the 'twirlies' to be running all 12 cores in parallel.

    This happened several times before I figured out what was happening - I'd start it running in SMP mode and leave, and come back later to find it in single core mode.... (Could this be considered a bug? IMHO if a program crashes it should freeze and preserve the evidence, not reboot...)

    After I found this forum I read through the FAQ and tried the suggested disabling everything I could - but if I disable "Legacy USB" I can't enter SMP mode because my USB keyboard doesn't work (The mobo doesn't have PS/2 ports....) However leaving legacy USB on, and disabling all the USB ports except the ones the keyboard and mouse use, and turning off everything else in the BIOS that I can did not change the error.

    Am I correct in my assumption that this is a problem with Memtest86+ and not my memory or other hardware? (It might be a compatibility issue with my older machine??)

    Do you have any other advice or suggestions???

    DX79SR mobo, I7 CPU, 48GB RAM Geforce vid card

  2. #2
    I just tried something that appears to be working - Memtest86 has been running for over 50 minutes and is most of the way through Test 8 in SMP mode (I notice that in many of the tests only one core is active at a time, though it switches cores periodically - I assume this is normal???) What I did was go back into the BIOS (Again) and turned off hyperthreading (so only one thread per physical core) and all the virtualization support options. When restarting the status screen now only shows 6 cores instead of 12, which matches the CPU core count, but otherwise everything looks the same... I did not see anything about doing this in the FAQ here, or in the documentation anywhere on the Memtest86+ website. It might be worth adding? ex-Gooserider
    DX79SR mobo, I7 CPU, 48GB RAM Geforce vid card

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages